Portal TJGO PJD Indisponivél
Incident Report for BIPBOP
Resolved
This incident has been resolved.
Posted May 18, 2020 - 17:52 UTC
Update
We are continuing to investigate this issue.
Posted Apr 27, 2020 - 13:43 UTC
Investigating
We are currently investigating this issue.
Posted Apr 27, 2020 - 13:37 UTC
This incident affected: TJGO - PJD.